Currently, Glims works with Safari 3.0.4 (4525.18) and up.

Tested with Maverick/Safari 7 and Safari 6.1 .